Calender
Sun Mon Tue Wed Thu Fri Sat
 123456
78910111213
14151617181920
21222324252627
28293031   
<< May 2017 >>
広告
SEARCH

SELECTED ENTRIES
RECENT COMMENTS
RECENT TRACKBACK
CATEGORIES
ARCHIVES
LINKS
PROFILE
OTHERS
SKYPE
PC: skype.jojo.jp
chat
iPad: iphone.jojo.jp
chat call
THANKS



本日:
昨日:
多言語
広告
 ▼▲ 作業日報 ▼△
    What's under the hood?
<< 送別会 | main | 逆引き >>
PCボードNT7001にdebianを入れてみました
大須でジャンクで¥3,980で購入したPCボード(NT-7001新品)にdebianをインストールしてみました。
NT7001
 12V単一電源で動きますが、極性がわかりませんでしたので友人(Mさん)に調べていただきました(上の写真の黄色い方が+です、チップヒューズがついている方です)。消費電力をみてみると大体21W程度でした、12V2Aぐらいだと思います。12Vの2Aスイッチング電源を利用(¥1,600)

NT-7001
 やはりXはちょっと辛い感がありますが、デスクトップ環境はサーバ用途では必要ないと思いますので、車載用のPCやルータ等などに結構活用できると思います
 上の絵では真っ黒になっていますが、動画(.avi,.3gp)の再生もできました


 最初普通にdebian(CentOS,Asianux,TurboLinuxも同)をインストールしようとるすと途中でモニタの同期が取れなくなりました。
 それで、debianでは「GUIインストールモード」にてインストールすると(boot:プロンプトで installgui を入力)画面が正常に表示されるようになります。
 次に、grubインストールで「/boot/grub/stage1 not read correctly.」といわれエラーとなりました。
 調べてみるとなぜか/dev/hda1のパーティーション番号がFAT16になっています、それで、一旦CUIコンソールに抜け([SHIFT]+[F2-4]とか)FDISKでパーティーション番号を変更(ext3)して 「chroot /target」として「grub-install /dev/hda」とやる必要がありました
 インストールにはCFの転送レートのせいかもしれませんが、2時間以上かかりました。
 あ、それとカーネルパラメータで rootdelay=10 と root=/dev/hda1 を与えてやらないとなぜかmount rootfilesystemのところでとまります、、

Spec:
Script started on Sun Jun  1 04:03:30 2008

debian:/proc# cat /proc/cpuinfo 
processor	: 0
vendor_id	: CentaurHauls
cpu family	: 6
model		: 9
model name	: VIA Nehemiah
stepping	: 8
cpu MHz		: 733.271
cache size	: 64 KB
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr cx8 sep mtrr pge cmov pat
         mmx fxsr sse up rng rng_en ace ace_en
bogomips	: 1468.70

debian:/proc# dmesg
Linux version 2.6.18-5-686 (Debian 2.6.18.dfsg.1-17) (dannf@debian.org)
   (gcc version 4.1.2 20061115 
 (prerelease) (Debian 4.1.1-21)) #1 SMP Mon Dec 24 16:41:07 UTC 2007
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000d0000 - 00000000000d8000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000001dff0000 (usable)
 BIOS-e820: 000000001dff0000 - 000000001dff8000 (ACPI data)
 BIOS-e820: 000000001dff8000 - 000000001e000000 (ACPI NVS)
 BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
 BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
 BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
479MB LOWMEM available.
On node 0 totalpages: 122864
  DMA zone: 4096 pages, LIFO batch:0
  Normal zone: 118768 pages, LIFO batch:31
DMI 2.3 present.
ACPI: RSDP (v000 AMI                                   ) @ 0x000fa3f0
ACPI: RSDT (v001 AMIINT VIA_P6   0x00000010 MSFT 0x00000097) @ 0x1dff0000
ACPI: FADT (v001 AMIINT VIA_P6   0x00000011 MSFT 0x00000097) @ 0x1dff0030
ACPI: DSDT (v001    VIA APOLLO-P 0x00001000 MSFT 0x0100000d) @ 0x00000000
ACPI: PM-Timer IO Port: 0x808
Allocating PCI resources starting at 20000000 (gap: 1e000000:e0c00000)
Detected 733.271 MHz processor.
Built 1 zonelists.  Total pages: 122864
Kernel command line: rootdelay=10 root=/dev/hda1 
No local APIC present or hardware disabled
mapped APIC to ffffd000 (013ca000)
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
PID hash table entries: 2048 (order: 11, 8192 bytes)
Console: colour VGA+ 80x25
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 479548k/491456k available 
 (1541k kernel code, 11296k reserved, 576k data, 196k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay using timer specific routine.. 1468.70 BogoMIPS (lpj=2937407)
Security Framework v1.0.0 initialized
SELinux:  Disabled at boot.
Capability LSM initialized
Mount-cache hash table entries: 512
CPU: After generic identify, caps:
  0381b93f 00000000 00000000 00000000 00000000 00000000 00000000
CPU: L1 I Cache: 64K (32 bytes/line), D cache 64K (32 bytes/line)
CPU: L2 Cache: 64K (32 bytes/line)
CPU: After all inits, caps:
  0381b93f 00000000 00000000 00000000 00000000 000000dd 00000000
Compat vDSO mapped to ffffe000.
Checking 'hlt' instruction... OK.
SMP alternatives: switching to UP code
Freeing SMP alternatives: 12k freed
ACPI: Core revision 20060707
ACPI: setting ELCR to 0200 (from 0c60)
CPU0: Centaur VIA Nehemiah stepping 08
SMP motherboard not detected.
Local APIC not detected. Using dummy APIC emulation.
Brought up 1 CPUs
migration_cost=0
checking if image is initramfs... it is
Freeing initrd memory: 4383k freed
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: PCI BIOS revision 2.10 entry at 0xfdb51, last bus=1
PCI: Using configuration type 1
Setting up standard PCI resources
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
PCI quirk: region 0800-087f claimed by vt8235 PM
PCI quirk: region 0400-040f claimed by vt8235 SMB
Boot video device is 0000:01:00.0
ACPI: PCI Interrupt Routing Table [¥_SB_.PCI0._PRT]
ACPI: Power Resource [URP1] (off)
ACPI: Power Resource [URP2] (off)
ACPI: Power Resource [FDDP] (off)
ACPI: Power Resource [LPTP] (off)
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 *10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 *5 6 7 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 *6 7 10 11 12 14 15)
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
pnp: PnP ACPI: found 10 devices
PnPBIOS: Disabled by ACPI PNP
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
PCI: Bridge: 0000:00:01.0
  IO window: disabled.
  MEM window: dde00000-dfefffff
  PREFETCH window: d5d00000-ddcfffff
PCI: Bus 2, cardbus bridge: 0000:00:0a.0
  IO window: 00001000-000010ff
  IO window: 00001400-000014ff
  PREFETCH window: 20000000-21ffffff
  MEM window: 22000000-23ffffff
PCI: Bus 6, cardbus bridge: 0000:00:0a.1
  IO window: 00001800-000018ff
  IO window: 00001c00-00001cff
  PREFETCH window: 24000000-25ffffff
  MEM window: 26000000-27ffffff
PCI: Setting latency timer of device 0000:00:01.0 to 64
PCI: Enabling device 0000:00:0a.0 (0000 -> 0003)
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 6
PCI: setting IRQ 6 as level-triggered
ACPI: PCI Interrupt 0000:00:0a.0[A] -> Link [LNKD] -> GSI 6 (level, low) -> IRQ 6
PCI: Setting latency timer of device 0000:00:0a.0 to 64
PCI: Enabling device 0000:00:0a.1 (0000 -> 0003)
ACPI: PCI Interrupt 0000:00:0a.1[A] -> Link [LNKD] -> GSI 6 (level, low) -> IRQ 6
PCI: Setting latency timer of device 0000:00:0a.1 to 64
NET: Registered protocol family 2
IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
TCP established hash table entries: 16384 (order: 5, 131072 bytes)
TCP bind hash table entries: 8192 (order: 4, 65536 bytes)
TCP: Hash tables configured (established 16384 bind 8192)
TCP reno registered
audit: initializing netlink socket (disabled)
audit(1212259756.276:1): initialized
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Initializing Cryptographic API
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
00:07: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
00:08: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
PCI: setting IRQ 11 as level-triggered
ACPI: PCI Interrupt 0000:00:0b.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
ttyS2: detected caps 00000700 should be 00000100
0000:00:0b.0: ttyS2 at I/O 0xe400 (irq = 11) is a 16C950/954
ttyS3: detected caps 00000700 should be 00000100
0000:00:0b.0: ttyS3 at I/O 0xe000 (irq = 11) is a 16C950/954
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
mice: PS/2 mouse device common for all mice
TCP bic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
NET: Registered protocol family 8
NET: Registered protocol family 20
Using IPI No-Shortcut mode
ACPI: (supports S0 S3 S4 S5)
Freeing unused kernel memory: 196k freed
Time: tsc clocksource has been installed.
input: AT Translated Set 2 keyboard as /class/input/input0
ACPI: Processor [CPU1] (supports 16 throttling states)
8139cp: 10/100 PCI Ethernet driver v1.2 (Mar 22, 2004)
8139cp 0000:00:08.0: This (id 10ec:8139 rev 10) is not an 8139C+ compatible chip
8139cp 0000:00:08.0: Try the "8139too" driver instead.
8139cp 0000:00:09.0: This (id 10ec:8139 rev 10) is not an 8139C+ compatible chip
8139cp 0000:00:09.0: Try the "8139too" driver instead.
8139too Fast Ethernet driver 0.9.27
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 10
PCI: setting IRQ 10 as level-triggered
ACPI: PCI Interrupt 0000:00:08.0[A] -> Link [LNKB] -> GSI 10 (level, low) -> IRQ 10
eth0: RealTek RTL8139 at 0xec00, 00:01:da:00:d9:c4, IRQ 10
eth0:  Identified 8139 chip type 'RTL-8100B/8139D'
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 5
PCI: setting IRQ 5 as level-triggered
ACPI: PCI Interrupt 0000:00:09.0[A] -> Link [LNKC] -> GSI 5 (level, low) -> IRQ 5
eth1: RealTek RTL8139 at 0xe800, 00:01:da:00:d9:c3, IRQ 5
eth1:  Identified 8139 chip type 'RTL-8100B/8139D'
usbcore: registered new driver usbfs
usbcore: registered new driver hub
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller at PCI slot 0000:00:11.1
ACPI: Unable to derive IRQ for device 0000:00:11.1
ACPI: PCI Interrupt 0000:00:11.1[A]: no GSI
PCI: VIA IRQ fixup for 0000:00:11.1, from 255 to 15
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt8235 (rev 00) IDE UDMA133 controller on pci0000:00:11.1
    ide0: BM-DMA at 0xfc00-0xfc07, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xfc08-0xfc0f, BIOS settings: hdc:pio, hdd:pio
Probing IDE interface ide0...
USB Universal Host Controller Interface driver v3.0
hda: CF 2GB, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
ACPI: PCI Interrupt 0000:00:10.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
uhci_hcd 0000:00:10.0: UHCI Host Controller
uhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 1
uhci_hcd 0000:00:10.0: irq 11, io base 0x0000d000
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:10.1[B] -> Link [LNKB] -> GSI 10 (level, low) -> IRQ 10
uhci_hcd 0000:00:10.1: UHCI Host Controller
uhci_hcd 0000:00:10.1: new USB bus registered, assigned bus number 2
uhci_hcd 0000:00:10.1: irq 10, io base 0x0000d400
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:10.2[C] -> Link [LNKC] -> GSI 5 (level, low) -> IRQ 5
uhci_hcd 0000:00:10.2: UHCI Host Controller
uhci_hcd 0000:00:10.2: new USB bus registered, assigned bus number 3
uhci_hcd 0000:00:10.2: irq 5, io base 0x0000d800
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:10.3[D] -> Link [LNKD] -> GSI 6 (level, low) -> IRQ 6
ehci_hcd 0000:00:10.3: EHCI Host Controller
ehci_hcd 0000:00:10.3: new USB bus registered, assigned bus number 4
ehci_hcd 0000:00:10.3: irq 6, io mem 0xdffffd00
ehci_hcd 0000:00:10.3: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb4: configuration #1 chosen from 1 choice
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 6 ports detected
hda: max request size: 128KiB
hda: 3964464 sectors (2029 MB) w/1KiB Cache, CHS=3933/16/63, DMA
 hda: hda1
EXT3-fs: INFO: recovery required on readonly filesystem.
EXT3-fs: write access will be enabled during recovery.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
Yenta: CardBus bridge found at 0000:00:0a.0 [0000:0000]
Yenta: Enabling burst memory read transactions
Yenta: Using CSCINT to route CSC interrupts to PCI
Yenta: Routing CardBus interrupts to PCI
Yenta TI: socket 0000:00:0a.0, mfunc 0x00001000, devctl 0x66
Yenta: ISA IRQ mask 0x0000, PCI irq 6
Socket status: 30000006
Yenta: CardBus bridge found at 0000:00:0a.1 [0000:0000]
Yenta: Using CSCINT to route CSC interrupts to PCI
Yenta: Routing CardBus interrupts to PCI
Yenta TI: socket 0000:00:0a.1, mfunc 0x00001000, devctl 0x66
Linux agpgart interface v0.101 (c) Dave Jones
Yenta: ISA IRQ mask 0x0000, PCI irq 6
Socket status: 30000006
agpgart: Detected VIA CLE266 chipset
agpgart: AGP aperture is 64M @ 0xe0000000
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
irda_init()
NET: Registered protocol family 23
Real Time Clock Driver v1.12ac
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
input: PC Speaker as /class/input/input1
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378, irq 7 [PCSPP,EPP]
input: ImExPS/2 Generic Explorer Mouse as /class/input/input2
cs: IO port probe 0x100-0x3af: excluding 0x170-0x177 0x370-0x37f
cs: IO port probe 0x3e0-0x4ff: excluding 0x4d0-0x4d7
cs: IO port probe 0x820-0x8ff: clean.
cs: IO port probe 0xc00-0xcf7: excluding 0xc00-0xc7f
cs: IO port probe 0xa00-0xaff: clean.
cs: IO port probe 0x100-0x3af: excluding 0x170-0x177 0x370-0x37f
cs: IO port probe 0x3e0-0x4ff: excluding 0x4d0-0x4d7
cs: IO port probe 0x820-0x8ff: clean.
cs: IO port probe 0xc00-0xcf7: excluding 0xc00-0xc7f
cs: IO port probe 0xa00-0xaff: clean.
ts: Compaq touchscreen protocol output
ACPI: PCI Interrupt 0000:00:11.5[C] -> Link [LNKC] -> GSI 5 (level, low) -> IRQ 5
PCI: Setting latency timer of device 0000:00:11.5 to 64
EXT3 FS on hda1, internal journal
loop: loaded (max 8 devices)
device-mapper: ioctl: 4.7.0-ioctl (2006-06-24) initialised: dm-devel@redhat.com
pcmcia: Detected deprecated PCMCIA ioctl usage from process: discover.
pcmcia: This interface will soon be removed from the kernel; please expect
  breakage unless you upgrade to new tools.
pcmcia: see http://www.kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html for details.
ACPI: Power Button (FF) [PWRF]
ACPI: Power Button (CM) [PWRB]
ACPI: Sleep Button (CM) [SLPB]
lp0: using parport0 (interrupt-driven).
ppdev: user-space parallel port driver
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
eth1: link down
[drm] Initialized drm 1.0.1 20051102
ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
[drm] Initialized via 2.7.4 20051116 on minor 0
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
debian:/proc# 


08/06/10 追記:
 あれから日本テクトの問い合わせフォームにて簡単な図面か、仕様書がないのか問い合わせたのですが、HPが更新されて、NT-7001のサポートはしない旨が明記されていました
 NT-7004が次モデルとしてでているようですが、実際の値段設定はどほれどなんでしょうか・・

08/07/27 追記:
このボードへのdebianインストールですが、問題が起こることがあるようです、
a-i2000の無能ログ様のサイトにて色々テストされています

a-i2000さま情報ありがとうございました

リンク:
日本テクト:NT7001
| Linux | 20:14 | comments(3) | trackbacks(1) |
はじめまして。
a-i2000と言います。

私もNT-7001を購入しましてイロイロ設定を行っています。
しかしながら、memtest86+のTest5でメモリエラーが頻発してしまいます。
メモリを2、3交換して試しましたが解消しません。
都合良く動作したと思いましたが、やはりエラーが頻発します。

こちらの記事を読む限りですと、問題は発生していないようにお見受けしました。
何か、特別に設定を行ったりしたのでしょうか?
また、Linux側で対処しているのでしょうか?
ヒントだけでも良いのでご教授願えないでしょうか。
| a-i2000 | 2008/07/23 12:34 AM |
a-i2000さま
コメントありがとうございました。
ブログも拝見させていただきました、もともと低消費電力が売りのC3系だった思うのですが、CPU温度がトンでもないことになっているような気が・・かなり苦労しておられるようで目頭が熱くなりました。。

自分の方は普通にdebianをスワップはなしでインストールしただけです、、確か

特にブログにあげている問題(VGA系等)以外は発生しませんでしたし、数日間動作テストもやってみましたが、気になる所もなかったのでメモリテストは行いませんでした
 それでネットワーク、音声関連機器等の他に利用出来ればと思いもう2台ほど購入した次第です
(そして今は眠っています・・)

以前に日本テクトに問い合わせフォームより色々情報を確認したところ正規出荷品には全てシリアルが付くそうで、無い製品に関しては答えられないということでした。
 従って、ご自身でもご指摘されていますが、手元にあるのは例外的なルートで流通してきたジャンク品だと思います(本来4万は下らないスペックだと思いますので・・)

もしかしたらチップセットかキャッシュメモリ不良、熱暴走の線が濃いように思いますが、

よかったら私のボードで試してみますか?

まだ気力がおありであればメール頂ければと思います
blog@jojo.jp
| ジョジョ | 2008/07/23 1:56 AM |
お・・・・おぉぉぉぉ??
追記情報に私のblogが・・・・
うれしい限りですが、私個人のトライの経過とメモなんで、早とちりや、ボンミスがあるかもしれないですよ。

ジョジョさんの方では正常に動作しているとのことですのでもしかしたら私の引いたボードがはずれクジだったり、ケースへの組みつけの際になにやら良からぬ自体が発生しているとも考えられます。
(もちろん、排除したつもりではいますが・・・)

メモリテストで問題が出ているのでDebianとの問題というよりはハード的な問題がOSへ波及していると今は考えていますので、その辺りの配慮お願いします。
人柱は好きですが、情報の質に自身は・・・・あまり無いです。orz
メモリの相性はぶつかると本当に抜け出しにくいものですね。
ここで、PC2100メモリに戻したら正常に動いてしまいそうで、それはそれで苦労が水の泡になるので、恐ろしい限りです。

長文、乱文で失礼しました。
| a-i2000 | 2008/07/29 11:55 AM |









http://blog.jojo.jp/trackback/923280
とりあえずがんばってDebian入れ直した。
苦労したぜ。セットアップ中に何度止まったか・・・・。エアコンがついてても切れててもエラーが出るときは出る。動けば何とか完走するが、しないときは何度やってもダメ。とりあえ...
| a-i2000の無能ログ | 2008/07/27 2:44 PM |